Welcome to Software Development on Codidact!
Will you help us build our independent community of developers helping developers? We're small and trying to grow. We welcome questions about all aspects of software development, from design to code to QA and more. Got questions? Got answers? Got code you'd like someone to review? Please join us.
Post History
Regarding length, the correct answer used 43 characters, but one was a space serving no purpose, so say 42 for: =CONCATENATE(LOWER(MID(A1,1,1)),LOWER(B1)) Most obviously, the concatenating functi...
Answer
#2: Post edited
- Regarding length, the correct answer used 43 characters, but one was a space serving no purpose, so say 42 for:
- =CONCATENATE(LOWER(MID(A1,1,1)),LOWER(B1))
- Most obviously, the concatenating function is a great deal less compact than an `&`:
- =LOWER(MID(A1,1,1))&LOWER(B1)
- Then applying the LOWER function twice is inefficient:
- =LOWER(MID(A1,1,1)&B1)
- Finally, since without parameters, LEFT() is easier to read than MID():
- =LOWER(LEFT(A1)&B1)
- This is less than half the length and, at least for me, clearer.
- Regarding length, the correct answer used 43 characters, but one was a space serving no purpose, so say 42 for:
- =CONCATENATE(LOWER(MID(A1,1,1)),LOWER(B1))
- Most obviously, the concatenating function is a great deal less compact than an `&`:
- =LOWER(MID(A1,1,1))&LOWER(B1)
- Then applying the LOWER function twice is inefficient:
- =LOWER(MID(A1,1,1)&B1)
- Finally, since without parameters, LEFT() is easier to read than MID():
- =LOWER(LEFT(A1)&B1)
- This is less than half the length and, at least for me, clearer.
- Applies equally to Sheets.
#1: Initial revision
Regarding length, the correct answer used 43 characters, but one was a space serving no purpose, so say 42 for: =CONCATENATE(LOWER(MID(A1,1,1)),LOWER(B1)) Most obviously, the concatenating function is a great deal less compact than an `&`: =LOWER(MID(A1,1,1))&LOWER(B1) Then applying the LOWER function twice is inefficient: =LOWER(MID(A1,1,1)&B1) Finally, since without parameters, LEFT() is easier to read than MID(): =LOWER(LEFT(A1)&B1) This is less than half the length and, at least for me, clearer.