Welcome to Software Development on Codidact!
Will you help us build our independent community of developers helping developers? We're small and trying to grow. We welcome questions about all aspects of software development, from design to code to QA and more. Got questions? Got answers? Got code you'd like someone to review? Please join us.
Comments on C naming convention, module trigrams?
Parent
C naming convention, module trigrams?
For my company, I'm writing naming conventions for embedded code in C language.
- Function names must be named in lowerCamelCase() and start with a verb.
- Global variables are in Maj_started_lower_case and are noun groups.
Exemple:
void initCanDriver();
uint8_t *Can_driver_buffer;
I have propositions to start our names with a module trigram? Exemple:
void CDR_init();
uint8_t *CDR_buffer;
Pros of trigram methode:
- clearly identify modules (and force to have modules)
- avoid duplicate names
Cons of trigram methode:
- actually, the majority of our codes don't really have modules, how to name a new function inside? We would have to define all modules.
- often less readable [you have to know CDR is CAN Driver]
Do you think it is a good idea?
Post
Personally, I don't like the first form (initCanDriver) at all.
The routine name is supposed to present some information as to where/how the routine fits into the larger software world. Information is best presented in global to local context order. This is because the local information often makes no sense outside of its context hierarchy.
To me, "CanDriverInit" or "CanDriver_init" is much better. It also has the advantage that all the CAN driver routines will show up in a sorted list next to each other. That can be useful.
I think the concept behind "CDR_init" is OK, but the implementation is lacking. Only three letters to indicate the package or library is too cryptic. In this case, someone seeing just "CDR" won't have much of a guess what the library is about, and there is a significant possibility of a name collision in the future. "CANDR" would already be much better in my opinion.
I do appreciate the effort to minimize gratuitous typing somewhat. Long routine names distract the mind to get the name right instead of what the code is supposed to do at that point, and reduce the space for end of line comments.
In the end, it's a judgement call based on how you value the various tradeoffs. There is no universal right answer. Personally, I like the "CanDriverXxx" or "CanDriver_xxx" naming schemes, but wouldn't be too opposed to "CANDR_xxx" or "CanDr_xxx". I'd really not like "CDR_xxx".
0 comment threads